Failed showing logs in TigerGraph Studio AdminPortal

Problem

N/A

Error message

When trying to read log files from the TigerGraph Studio AdminPortal. It shows "Bad Request" and "Path to the logs was invalid". image::bad_request.png[Error message]

Diagnosis

Checking the configuration file, the log path has a double “/“.

Workaround

Modifying the "System.LogRoot" value to the correct path.

Solution

Running the below command and entry into the system config, then modify the "System.LogRoot" value to correct path:

gadmin config entry system
image::gadminlog.png[Gadmin log root]

Then apply the config and restart the service:

gadmin config apply
gadmin restart all

After modifying the path to the correct value, then applying the config and restarting the service, the scenario comes to normal.